Regis

W205 C200 transmission problem

5 posts in this topic

Hi guys,

my c200 recently experienced a jerky change of gear especially in 3rd to 4th gear, the gear will always stuck at 3rd gear without moving to the 4th despite rpm over 3.5 in comfort mode. And the whole car keep jerking and the engine checklight just lighted up not long ago. This morning i brought the car to the eorkshop which they run a diagnostic test and they can’t seems to find any fault code. Could someone advise me what could be the reason? Thanks in advance :)A470F314-39AB-4FD8-99F0-D4EE4B8AF304.thumb.jpeg.bea8831ad218fa5c2851bd9d7942c7d7.jpeg

Share this post


Link to post
Share on other sites

It sounds like your gearbox is breaking or broken. Has it only happened once or does it always happen? If it always happens and your workshop can’t diagnose the issue, you should change workshop. If it only happened once, you can try changing transmission fluid and hope that it doesn’t happen again. 

Share this post


Link to post
Share on other sites

Maybe speed sensors fail

Share this post


Link to post
Share on other sites

I sent to cycle they diagnose that one of the harness fails that explains the engine checklight  being turned on. The jerking is the vehicle in limp mode preveting me from overdriving.

1 person likes this

Share this post


Link to post
Share on other sites
On 3/28/2019 at 1:56 PM, Regis said:

I sent to cycle they diagnose that one of the harness fails that explains the engine checklight  being turned on. The jerking is the vehicle in limp mode preveting me from overdriving.

Can you let me know what kind of harness?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now