Jump to content
  • Join SGMerc for Exclusive Perks!

    Welcome to SGMerc - the largest Mercedes-Benz site for Owner and Enthusiasts in Singapore!

    SGMerc is the official club for all current & previous owners of Mercedes-Benz cars in Singapore.Ā SIGN UP FOR YOUR FREE ACCOUNT TODAY!

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple,Ā join us today!

Vibration C180 9G


Recommended Posts

Anyone having this issue during cold starts the car vibrates? Getting this even after cold starts after driving sometime (when I'm stopped at the traffic lights).

Authorised after sales says to me it is the characteristic of the car šŸ˜³

Link to comment
Share on other sites

  • 1 month later...
On 3/5/2018 at 9:43 AM, Wong71 said:

RPM idling is at 600 (and it is a trembling sensation) and not the engine knocking.

The idling is not inconsistent ... as it is always at 600.Ā 

My car started vibrating during idle when the Sales was going through the features with me during collection. I highlighted the issue and he told me he don't feel anything. RPM stable at 600 rpm also, vibration comes on and off for me. Have an appointment with C&C in 2 weeks to check it out. Is your car still under warranty?

Link to comment
Share on other sites

On 4/6/2018 at 3:49 PM, knighthunter said:

I had this issue with C180 W204 when I fill up with RON 95 Problem goneĀ if fill up with RON98

I'mĀ on Shell 98 since day 1. Still encountering the issue.Ā 

Link to comment
Share on other sites

  • 2 weeks later...

I checked with my SA and he did a test drive of the car. His diagnosis is the vibration comes from the air con compressor kicking in as the vibration goes away with the air con off.Ā 

Link to comment
Share on other sites

  • 4 months later...
  • 1 month later...

Have you guys solved your problem of vibration? Is your car due for servicing of the transmission? Just change your transmission oil and transmission filter, plus changedĀ the engine mounting and the gearbox mounting, total 3 and your issue will be resolved. My car has the same problem for the past 6 months, and during that time, I changed nearly everything from spark plugs, throttle oil, fuel injection service and more but issue just couldn't be resolved. Fuel consumption increased by between 20-30% during this period. In the end, this last move resolved the problem. Monitoring the FC now. Hopefully, it will come back down by the same margin.

  • Like 1
Link to comment
Share on other sites

  • 5 years later...

I have the same issue. Vehicle is 2 years old. W205. Engine started developing this recently - start car, vibration will occur during idle from 8,000-9,000 and only goes away when idling drops to 7,000. Cycle & Carriage says itā€™s normal and other customer cars also have this. My question is - why does it happen 2 years after buying the car? They said they find no faultĀ 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...