Jump to content
jtauto

Need HELP

Recommended Posts

Hi I have recently replaced original new parts for the followings

1) front & rear shock absorber (incl. mounting, stopper & dust cover)

2) upper & lower arm + bushing

3) engine & gearbox mounting

4) 4 x Michelin Pilot Sport 4 tires

However my car still feel very "bumpy" & "shaky" when in motion on uneven road.

What else could be the cause of it???

Desperately need some advice.....TQVM

J.T.

Share this post


Link to post
Share on other sites

If I were you....I'll change the workshop.

Share this post


Link to post
Share on other sites
Will appreciate if anyone can recommend a workshop for change of suspension.
Model E200 / Reg Date:3/5/2012
Milelage already 140K.
Cheers

 

Share this post


Link to post
Share on other sites

Generally after changing the below, an alignment is needed.

1) front & rear shock absorber (incl. mounting, stopper & dust cover)

2) upper & lower arm + bushing

3) engine & gearbox mounting

4) 4 x Michelin Pilot Sport 4 tires

"bumpy" feeling a expected but "shaky" is not.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...