Smokeout78

CLA200 Erratic Turbo Boost/Charge

3 posts in this topic

Dear all CLA enthusiasts,

i have been driving my CLA200 for the last 2 years and recently I have encountered an erratic turbo boost especially when I step harder on the accelerator. The turbo boost will come back on and off and I have recently sent it to a workshop for repair. The preliminary investigation could be due to a faulty turbo boost/charge sensor pressure. But after the replacement, the fault persisted. Just like to ask if any of  you guys have encountered the same problem and don’t mind share with me what is the main issue. Thank you and appreciate it:) 

 

Regards,

Smokeout 

1 person likes this

Share this post


Link to post
Share on other sites

My W176 A200 had loss of turbo boost issue due to faulty turbo actuator. Can bring your car to Chip Soon to diagnose if it's the same issue. They have done quite a no of actuator replacements according to the mechanic.

1 person likes this

Share this post


Link to post
Share on other sites

I’m driving a cla180. Had this problem few months back,took the workshop quite a while to figure out that it’s the turbo valve cap being stuck and unable to open/close. 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now