tws.anthony

CLA180 Aircon Hissing Sound

10 posts in this topic

Hi all gurus,

I am driving a Cla180 but I keep hearing a hissing sound from the aircon. When i travel at high speed, I can't really hear the sound. However when i am coming to a stop, the hissing sound gets loud and it's quite irritating. The aircon is still cold all the way which I find it weird. Sent down my car to a workshop also doesn't help. So i went to Tomika to get it fixed but they can't identify the problem and just changed a valve, vacuumed and change the compressor oil. After driving for 5 mins, it's back to normal again. Gas wasn't leaking according to them. Am very irritated with the sound and after spending money to get it fixed, it's still the same.

Would like to ask if anyone faced this issue and get it solved? Thanks so much in advance! :)

 

Share this post


Link to post
Share on other sites

Just backtracking a little - not that I doubt what you are saying, are you really sure it is from the aircon? Where exactly you hear the sound coming out from - e.g vents, footwell etc? And when you say coming to a stop, does it mean only when you apply brakes?

 

 

Share this post


Link to post
Share on other sites
1 hour ago, dchum said:

Just backtracking a little - not that I doubt what you are saying, are you really sure it is from the aircon? Where exactly you hear the sound coming out from - e.g vents, footwell etc? And when you say coming to a stop, does it mean only when you apply brakes?

 

 

I am sure it is from the aircon because once i off it, the sound is gone. I hear it coming from behind the dashboard. The sound  gets louder when I am travelling low speed or coming to a stop. Even when I am stationary the hissing sound is there till I off the aircon.

Share this post


Link to post
Share on other sites
25 minutes ago, vectrasonic said:

Did you replace the cabin air filter recently? Could be alignment issue of the filter.

Hi, I replaced it recently as the workshop thought that could have caused it but it is still the same. No idea what is wrong and I am wondering if the culprit could be the compressor?

Share this post


Link to post
Share on other sites

Its pretty normal. It happens to my W211 after a new aftermarket AC filter.

The hissing sound comes on and off, its more pronounce in quiet moment (night time..etc). Its usually means the compressor is working hard and circulating the freon in the system.

Just ignore it. It shows the AC is working fine.

Share this post


Link to post
Share on other sites

can try aircon flushing.

 

happened to my w204 last time.. very irritating once you hear the hissing sound.. in the end did a flushing and the hissing is gone.

Share this post


Link to post
Share on other sites

in this case i think compressor maybe the culprit, perhaps go gentler on the temperature, else u would find yourself out of freon in a year.

Share this post


Link to post
Share on other sites
On 3/16/2018 at 7:45 PM, giggss said:

can try aircon flushing.

 

happened to my w204 last time.. very irritating once you hear the hissing sound.. in the end did a flushing and the hissing is gone.

I have done a flushing but to no avail. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now