Jump to content

Search the Community

Showing results for tags 'starter'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SGMerc General
    • Latest Announcements
    • Introductions & Greetings
    • SGMerc Events & Gatherings
  • Site Sponsors
    • Audio & In-Car Entertainment
    • General Workshop & Modifications
    • Car Care & Detailing
    • ECU Tuning
    • Motor Insurance
    • Paint & Body Shop
    • Parallel Importers
    • Wheels & Tyres
    • Window Tinting
  • Mercedes-Benz General Chat
    • General Mercedes-Benz Chat
    • Power Modifications
    • Exterior & Interior Styling
    • Handling Section
    • I.C.E. (In Car Entertainment)
    • International Mercedes-Benz News (RSS)
  • Mercedes-Benz Model Specific Chat
    • Mercedes AMG Models (36, 43, 45, 55, 63, 65 AMG)
    • Core Models
    • Coupe / Convertible
    • Off-Road Vehicles / SUV / MPV
    • Roadster
    • Classic Mercedes-Benz (MY85 & Older)
  • Showroom
    • Showroom
  • Private Classified Ads
    • Want-to-Sell (Car Related Items ONLY)
    • Want-to-Sell (Non-Car Related Items)
    • Want-to-Buy
    • SGMerc Car Mart
  • Other Car Marques
    • Other Car Makes Discussion
  • General Chat
    • The 3 Pointed Star Bar
    • Makan Makan!
    • Photography
  • Feedback
    • Feedback & Suggestions
    • Technical Support & Testing

Categories

  • SGMerc News
  • Internation Mercedes-Benz News

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Mercedes-Benz Owned

Found 1 result

  1. Hi, This is quite a long post regarding gear shifting / starter problem and as of now, problem not resolved yet. Hopefully, some bros can shed some light. Car: Year 2012 W212 Problem 1 (gear shift to 'P' or 'N' by itself) The problem first started about 2 months ago when I stop at a traffic light and I felt a small jerk. Realised the gear has shifted to 'P' by itself. I couldn't shift back to 'D', until I switch off and restart the engine. Afterwards, all is ok, the car run smoothly. However, a few days later, when slowing down (not complete stop yet), the car will shift to neutral by itself. Same thing, I couldn't shift it back to 'D' until I switch off the engine. The check engine light also came on. This happens intermittently over the next few days/weeks. Problem 2 (starter cannot crank) Living with problem 1 for a few weeks, when starting the car one morning, I can feel the starter crank once (split second thingy) and stop. After trying a few times, manage to start and driving was smooth after. Similarly, the starter problem happen a few more times over the next few weeks. Decide to bring car to workshop. Assessment 1 First diagnosis naturally points to faulty starter. After changing, cannot start still. Lucky it happen while still at the workshop. So concluded its not a starter motor issue. Workshop was very proactive to reverse the repair and kept the car for further diagnosis. Assessment 2 Car was left overnight for diagnosis and was informed that Problem 2 was caused by a faulty Intelligent Servo Module (ISM). https://mechvibesblog.com/intelligent-servo-module/ Replaced the ISM Post repair - Day 1 The car seems to be cranking and starting smoothly after changing the ISM. However, on the night itself, the gear shifted to neutral again while at slow speed. Check engine light came on again. Called the workshop. The quick assessment is that it is two separate and different problem e.g. gear shift by itself and starter issue. Meaning that the ISM have resolved the starter issue while the gear shifting by itself is a separate problem. Possible the conductor plate? Nonetheless, was told to monitor and continue driving. Post repair - Day 7 Today, the car once again did the dreaded spilt-second crank and stop 😫. Have to retry 3-4 times before starting the engine. This is after 6-7 days of smooth cranking after changing the ISM. Diagnosis??? So the big question now is, are the 2 problems related? It seems like there is a sequence to it? The gear shifting to neutral by itself first, and a week or 2 later, the starter problem will surface? Perhaps problem 1 leads to problem 2? Thanks for reading, and any help or comment is much appreciated! Will post result and outcomes when/if i solve the problem.
×
×
  • Create New...