mike9956

Members
  • Content count

    75
  • Joined

  • Last visited

  • Days Won

    9

mike9956 last won the day on April 20

mike9956 had the most liked content!

Community Reputation

6 Neutral

About mike9956

  • Rank
    1st Gear

Profile Information

  • Gender
    Male
  • Location
    singapore
  • Mercedes-Benz Owned
    S300L

Recent Profile Visitors

800 profile views
  1. Hi, visited Uncle Tony (Trendy Auto) today. He and Ah Teck (1st mechanic) were very meticulous in diagnosing the undercarriage noise. Conducted 3 test run (at driver seat, at passenger seat and at back seat) over uneven road in order to pinpoint the noise. Narrowed down to front left section. Dismantled the lower control arm, thrust arm and stabiliser bar. Inspected the joints and brushes. All found normal. During re-assembling, they applied a copper-coloured coating (appeared like liquid latex) on all the major bolts, screws and brushes as an anti-friction protection (most mechanics can't be bothered with such task). Eventually, nailed down to the front left suspension struts. He dismantled (very tedious task) the struts. Opened up the dust cover and big-O-rings. Use WD-40 and compressed air to clean up the dirt and oiled the internal rods. From my past experience, no workshop was willing to open up and oiled/clean the strut interior (see attached photo). Most will insist you to buy a new pair (not just the faulty unit) - taking the easy and most profitable way out but burned a big holes in customer's wallet. Bottom line, instead of paying for 1 pair of new front strut , 1 air pump and 1 block value for a quote close to $4k by another workshop, I gladfully paid $320 for his team's 5 hrs of workmanship. Once again, I must thanks member RX7EFFINI for his recommendation. I was tempted to keep good things to myself, as a secret !!! There again, nowadays we are living in an 'information sharing' society and obliged to share the good. Besides, it is a gem discovering honest and experienced mechanics who doesn't take the easy way out and do take pride in repairing stuff. Why replace where you can repair,,,the strut will now be good for another 25-30kkms. In our 'disposal-whatever' society, repair has increasingly becomes a dying word Have a good weekend...cheers...mike Like they said...happy like a toad. Saved myself a couple of thousands
  2. Thanks for your comment. I will get a second opinion from uncle Tony... Appreciate your recommendation. By the way, what was your symptom that require to change the block valve?
  3. Hi , good day ! Went to a workshop at Upp Thomson to check on front undercarriage low-level metal-grinding noise. Very likely caused by front airmatic suspension struts. Service Advisor quoted me 1 pair (insist on 1 pair . Otherwise, the other with fail soon after). In addition, he insisted I ought to replace the air-pump and solenoid block valve to ensure 100% no problem with the airmatic system, after the struts replacement. I would like to seek comments from you guys whether this is the norm or an overkill solution to the grinding-noise issue. Recently, I noticed that every time I start up the car, the 'car-rising' lamp on the top-right main-display lighted up for about 5 secs and then off. In the past, it was about 2-3 secs. Unsure if that has anything to do with the air pump or block-valve ? Appreciate your opinion Thanks...mike
  4. Hi all, good day I found a cheap solution... went to a neighbourhood accessories shop. Dismantle the headlight and apply sealing tape around the rubber seal. Plus clear blockage at the 'breathing hole' on the headlamp. Completed task within 30mins for $65. Cheers
  5. Hi all, good day I have resolved the problem. Buy (in my case from Aliexpress) reverse backup camera WITHOUT mirror image feature . The mirror image caused rear right-hand-side object appears as left-hand-side image on the original screen/monitor. Cheers...mike
  6. Hi SQ88, good day and thanks for the valuable information. It makes more sense to just change the seal
  7. Hi, In my case, if I want DRL only. I turn the switch another notch after AUTO. The symbol is 2 small lights facing each other.
  8. Hi All , good day. Mine is W221 year 2010 (original facelift model). After heavy rainfall, I found my left head lamp has heavy condensation. The right head lamp is perfect. However, the lights are all working. It usually takes 2-3 days to clear up. I afraid the condensation may someday short-circuit the lightings and cause fire. I did a simple visual inspection (just open up the bonnet) and didn't see any crack on the plastic housing. I went to a reputed workshop in Bukit Merah, the guy said, change the head lamp ($1,800 - OEM). It's like one is riding in a W221 and in heavy rain. Found condensation on the internal side of the windscreens or windows, does one has to change the car ?? Anyone has a sensible low cost solution ? Appreciate your comment Sorry for the grumbling...cheers...mike
  9. thanks for your reply. I know and it's a lesson learnt. A case of penny wise, pound foolish. Is there a local shop I could buy the reverse cam with installation ? or have to buy original from Cycle ?
  10. Hi All, Good day. Car is W221 S300L year 2010 (facelift model). Several weeks ago, my Reverse Camera image was blurred. Installed a replacement unit from Aliexpress online (OEM type) but rear view Left-hand-side object shows up on the car original monitor/screen on the RIGHT-hand-side of the screen. So cannot be used as left and right image is reversed. The correct view is, rear view left-hand-side object will appear as left-hand-side image on the monitor/screen. Visited two electrical accessories shop and after $250 poorer, no solution was found. The sad part is that the OEM reverse cam cost only $36. Has anyone came across such problem and its solution ??
  11. Hi All, Good day. Car W221 S300L year 2010 (facelift model). Several weeks ago, my Reverse Camera image was blurred. Installed a replacement unit from Aliexpress online but rear view Left-hand-side object shows up on the car original monitor/screen on the RIGHT-hand-side of the screen. So cannot be used as left and right image is reversed. The correct view is, rear view left-hand-side object will appear as left-hand-side image on the monitor/screen. Visited two car electrical accessories shop and paid $250+ labour cost, problem could not be resolved. Any of you guys has a solution ?? Thanks...mike
  12. Hi J888, Thank you so much for your suggestion. May I know where are the wheel speed sensor located and how many sensor are there ? Cheers...mike
  13. Hi friends, Good day . I have a W221 year 2009. I encountered while driving, the dashboard display suddenly shows Drive -with 2 or 1 on the right side of the display. The car unintentionally shifted down to 2 or 1 gear, even though I am on 'S' mode. I had to pull to a stop and then manual shift from Drive to Neutral. Shift back to Drive and move off without further problem. I have 8 more months to scrap and trying to 'ta-han' as long as practical. Recently, such occurrence became more frequent and I am concern about safety. Appreciate guidance or tips on the likely cause and solution Thank you
  14. Great stuff...talking about power booster. Has anyone tried X1-R (made in USA and NASA endorsement) EON95 boosted to EON98. If full tank, would save about $18 (based on diff pump price between EON95 with EON98, I was at KSL City (JB) fortnight ago and this salesperson was promoting and got a free sample btl. Have try as yet. Afraid it might cause engine trouble inspite of USA product and NASA tested/certified Enjoy your weekend...mike